Browse Source

feat: add support for volumeAttributes to aws-efs-csi-driver to allow to disable buggy TLS encryption

pull/40/head
Stefan Reimer 1 year ago
parent
commit
0edbf55850
  1. 2
      charts/kubezero-aws-efs-csi-driver/Chart.yaml
  2. 21
      charts/kubezero-aws-efs-csi-driver/templates/efs_pv.yaml
  3. 8
      charts/kubezero-aws-efs-csi-driver/templates/efs_pvs.yaml
  4. 6
      charts/kubezero-aws-efs-csi-driver/values.yaml

2
charts/kubezero-aws-efs-csi-driver/Chart.yaml

@ -1,7 +1,7 @@
apiVersion: v2
name: kubezero-aws-efs-csi-driver
description: KubeZero Umbrella Chart for aws-efs-csi-driver
version: 0.3.4
version: 0.3.5
appVersion: 1.2.0
kubeVersion: ">=1.18.0-0"
home: https://kubezero.com

21
charts/kubezero-aws-efs-csi-driver/templates/efs_pv.yaml

@ -1,21 +0,0 @@
{{- if .Values.PersistentVolume }}
{{- if .Values.PersistentVolume.create }}
apiVersion: v1
kind: PersistentVolume
metadata:
name: {{ default "kubezero-efs-pv" .Values.PersistentVolume.Name }}
labels:
{{ include "kubezero-lib.labels" . | indent 4 }}
spec:
capacity:
storage: 5Gi
volumeMode: Filesystem
accessModes:
- ReadWriteMany
persistentVolumeReclaimPolicy: Retain
storageClassName: efs-sc
csi:
driver: efs.csi.aws.com
volumeHandle: {{ .Values.PersistentVolume.EfsId }}
{{- end }}
{{- end }}

8
charts/kubezero-aws-efs-csi-driver/templates/efs_pvs.yaml

@ -16,10 +16,10 @@ spec:
csi:
driver: efs.csi.aws.com
volumeHandle: {{ .volumeHandle }}
{{- with .mountOptions }}
mountOptions:
{{- . | toYaml | nindent 4 }}
{{- end }}
{{- with .volumeAttributes }}
volumeAttributes:
{{- . | toYaml | nindent 6 }}
{{- end }}
{{- with .claimRef }}
claimRef:
{{- . | toYaml | nindent 4 }}

6
charts/kubezero-aws-efs-csi-driver/values.yaml

@ -31,9 +31,3 @@ StorageClass:
#
# - name: example-pv2
# volumeHandle: "<efs-id>:/path2"
# Deprecated and removed with next release
# PersistentVolume:
# create: false
# EfsId: ""
# Name: ""

Loading…
Cancel
Save