32 lines
881 B
Plaintext
32 lines
881 B
Plaintext
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
|
|
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
|
|
pkgname=cri-tools
|
|
pkgver=1.30.1
|
|
pkgrel=0
|
|
pkgdesc="CLI tool for Kubelet Container Runtime Interface (CRI)"
|
|
url="https://github.com/kubernetes-sigs/cri-tools"
|
|
arch="all !armhf"
|
|
license="Apache-2.0"
|
|
makedepends="go"
|
|
options="!check" # no check available
|
|
source="$pkgname-$pkgver.tar.gz::https://github.com/kubernetes-sigs/cri-tools/archive/v$pkgver.tar.gz"
|
|
|
|
export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
|
|
export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
|
|
export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
|
|
|
|
build() {
|
|
make all
|
|
}
|
|
|
|
check() {
|
|
make test
|
|
}
|
|
package() {
|
|
make BINDIR="$pkgdir"/usr/bin install
|
|
}
|
|
|
|
sha512sums="
|
|
c3a989ec57016a05a83adbabab7ec49da267f0d6cfc603a4cb8cb4699fe499c16b49e910fb6bfda413a57f45eb3a3d6f0a5c5b8d76895695ed3870343a0c4db9 cri-tools-1.30.1.tar.gz
|
|
"
|