fix: add pexpect to requirements, bump Python to 3.10

master v0.15.4
Stefan Reimer 1 month ago
parent f1bfbd3eea
commit d4cc665df4
  1. 4
      Dockerfile
  2. 1
      pyproject.toml
  3. 1
      requirements.txt

@ -1,6 +1,6 @@
ARG RUNTIME_VERSION="3.9"
ARG RUNTIME_VERSION="3.10"
ARG DISTRO_VERSION="3.16"
ARG PULUMI_VERSION="3.35.1"
ARG PULUMI_VERSION="3.35.3"
FROM python:${RUNTIME_VERSION}-alpine${DISTRO_VERSION} AS builder
ARG PULUMI_VERSION

@ -17,6 +17,7 @@ dependencies = [
"mock",
"Jinja2>=3.0.0",
"click",
"pexpect",
"cfn-lint>=0.34",
"python-minifier",
"pulumi>=3.35.0",

@ -2,6 +2,7 @@ boto3
mock
Jinja2>=3.0.0
click
pexpect
python-minifier
cfn-lint>=0.34
pulumi>=3.35.0

Loading…
Cancel
Save